Skip to content

Kirby 4.1.0

Requirements

Kirby has a couple system requirements to work properly

Web servers

If you want to use PHP's built-in server, you have to start it up with Kirby's router:

php -S localhost:8000 kirby/router.php

Other servers may work, but are not officially supported.

Server requirements

  • The server must support URL rewriting
  • The server OS must be POSIX compatible.

PHP Versions

  • PHP 8.3
  • PHP 8.2 (recommended)
  • PHP 8.1

PHP Extensions

Required Extensions

  • Either the gd extension or ImageMagick (see below)
  • ctype
  • curl
  • dom
  • filter
  • hash
  • iconv
  • json
  • libxml
  • mbstring
  • openssl
  • SimpleXML
  • PHP exif extension for support for EXIF information from images
  • PHP fileinfo extension for improved MIME type detection for files
  • PHP intl extension for the intl date handler (support for international dates) and localized number formatting

Optional Extensions

  • ImageMagick (convert binary) if you want to use the im thumbs driver. Note that the PHP exec() method must be enabled on your server in this case as well.
  • PHP apcu extension for the Apcu cache driver
  • PHP memcached extension for the Memcached cache driver
  • PHP PDO extension for connecting to databases
  • PHP zip extension for ZIP archive file functions
  • PHP zlib extension for sanitization and validation of .svgz files

Browsers for the Panel

Kirby does not modify the output of your site's templates and thus has no effect on the browser requirements for your site's frontend. However, the Panel is built on modern browser features and has a couple browser requirements which need to be met by your site's editors

Desktop Mobile
  • Firefox 110+
  • Chrome 106+
  • Safari 15+
  • Edge 106+
  • Opera 94+
  • Mobile Safari 15+
  • Android Browser 117+
  • Chrome for Android 117+

PHP Version Support History

Kirby PHP 8.3 PHP 8.2 PHP 8.1 PHP 8.0 PHP 7.4 PHP 7.3 PHP 7.2 PHP 7.1
^4.0.0
^3.10.0
^3.9.0
^3.8.0
^3.6.1
^3.6.0
^3.5.0
^3.4.0
^3.3.2
^3.0.0