🚀 Kirby 3.9 is here! Learn more
Skip to content

Migration guide for plugin developers

How to add support for Kirby 3.9 to your plugin.

Check if any breaking changes apply to your plugin

We try to avoid breaking changes as much as we can. But we also put a lot of effort in keeping our technical debt in Kirby as low as possible. Sometimes such breaking changes are necessary to move forward with a clean code base.

Kirby 3.9 is a major release and comes with deprecations and breaking changes. You can find them in the changelog. We cannot list all of these changes here as not all plugins are affected by all of these changes.

Please read through the deprecations and breaking changes and check if you are affected. In this case, please update your plugin code for compatibility with Kirby 3.9.

Note that your plugin will not support Kirby 3.9 if it is affected by a breaking change. In contrast, deprecated code will still work for the moment but will break in a future Kirby version.