This is an archived version of our old forum. Be aware that the solutions and questions mentioned here, might no longer be valid for Kirby 2! Please refer to our new forum for more recent questions and answers.

Panel not loading when on hosting server.

by john_wokka

Ive loaded my site files onto my server, but when I try to log into the Panel, I get the following error:

  Not Found 
  The requested URL /panel/login was not found on this server.

Any ideas what this could be about? All the folder permissions seem set appropriately (755) and the website works just as it did while locally on my computer running through MAMP. The only exception is I cannot get the panel to load.

Im hosting with MediaTemple on Apache/2.2.22 Server running PHP 5.3.29

2 Replies

by pauljmorel

I had a similar problem when setting up on my VPS (Ubuntu 14.04 64-bit). Apache rewrite wasn't working despite mod_rewrite being active and turned on via the .htaccess file. However, the .htacces file was being ingnored. I was getting 404s whenever the URL wouldn't correspond to an actual file.

I found out that my problem was my default Apache Virtual Hosts file located at /etc/apache2/sites-available/000-default.conf. It read:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

    ErrorDocument 404 /index.html

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Turns out, this config file wasn't allowing .htaccess to override default/server wide Apache settings, like mod_rewrite being off by default. I ended up adding the appropriate directives to allow .htaccess to override the settings. This is what my default vhost conf ended up looking like.

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        <Directory "/var/www/html">
            AllowOverride All
            Require all granted
        </Directory>
    ErrorDocument 404 /index.html

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

This fixed my problem. I don't know if this is your case as well, but it wouldn't hurt to check. Hope it helps!

by john_wokka

Thanks. It ended up being somewhat more simple and due to my inexperience. I thought I copied my .htaccess file over, and that it was just displayed invisibly on my sever like it originally was on my local drive, but it turned out that it was never transferred. I use Transmit as my FTP and that doesn't copy them over. I was told I needed to use FileZilla or some other FTP so I did but it also turns out that if you use Transmit (OS X) you can click View>Show Invisible Files and then you can copy over things like .htaccess

Our partners

CDN by KeyCDN Search by Algolia

Top